Back to Shopping at NorthernBrewer.com

Edelmetall Won't Light

I’m having an issue with my Edelmetall Bru Burner. I’ve done four 5-gal all-grain batches with it since I got it in Feb, no problems at all, worked great. About a week ago I was brewing up another batch of tasty saison, and about halfway through I needed to re-light the thing to start heating sparge water and I couldn’t get it to light. At the first attempt there was just a little flare-up, nothing major just the usual kind of thing, but after that it just wouldn’t light correctly. I fiddled and fiddled and the best I could get it to do was to light at extremely low output, the level at which you might be able to melt butter in a pot but certainly not heat 2+ gal of water. If I push more gas and try to light it, it just flares up and then goes out with the flame moving into the assembly where the regulator hose attaches. Needless to say that is a bit scary and I kill the gas pronto. I had to finish that batch using a barbecue grill, which was a PITA. I’ve let it sit for a week and tried to light it today - same results.

What gives? Any ideas? Could it be something with the regulator? The propane tank is full and works fine on the grill, and it doesn’t seem like there should be too much in the way of complicated parts in the burner itself to cause this kind of problem. I’m hoping it’s either me (doubtful, since I’ve tried about everything) or something easily fixed, as I’d like to not get into the hassle of sending it back to NB.

Thanks in advance.

Contact Northern Brewer customer service. They own the trademark to the Edelmetall brand. The user manual says to take it in for repair if you’re having the sort of trouble you’ve described…

On my blichman I have had problems with a newly filled propane tank letting liquid into the regulator which then freezes and obstructs the flow. Opening the regulator works momentarily but quickly drops back down to the same sort of low flame you describe. Pouring warm water over the regulator fixed the problem until the level dropped a bit.

Good thing to check. Those high output burners can use propane fast enough to freeze parts. The conversion from liquid to vapor draws heat form the walls of the tank. When it can’t convert fast enough it freezes. What I learned (right here) is to put the tank in a container of water. I use one of those plastic storage bins. You don’t have to completely submerge everything, just have the tank 1/2 or so in. I have not had a freeze up since.

That may not be the problem of course but an easy thing to check out.

BTW it is also an easy way to see when the tank is becoming empty because it will begin to float.

It my case it was plenty hot out to vaporize propane in the tank. I think the problem was that it was so full, and in fact still cold from the filling process, that it was spraying liquid up into the regulator where it did not have nearly as much surface area to absorb heat as the side of the tank. I think when you propane exchange they give you tanks with a bit of headspace, but the refilling station just fill until it overflows. The tank was not especially cold to the touch, but the regulator body was below freezing.

Whenever possible I now use fresh tanks on the grill for a while first, then rotate to the burner (usually still 90% full).

I had a gas grill once that would not work properly. It turned out that a spider had made a nest in the cavity where the gas and air mix. You may want to check for spiders. There is very little that can go wrong with a simple gas burner. So if it was working and then stopped then it’s probably something silly like that.

I would just like to throw out a hearty thumbs up to the fine folks from the NB customer service dept - not only did they contact me independently as a result of this posting, but they sent me a UPS label for the return pronto, which barely after getting the thing dropped off at UPS the next day I had already received a delivery notice that the replacement was on its way. Total time without a burner - one day. ONE FREAKING DAY.

Bravo, sirs. Bravo.

Sincerely,
Future Repeat Customer For Life

Okay, this sucks. I got the Edelmetall burner a couple weeks ago, brew day is tomorrow (Sunday) so I figured I’d try it on Saturday afternoon, get it hooked up with propane, etc., since I’ve never used a burner like this. I get it set up, light it, and…nothing. The flame lights in the Venturi, and when I turn the regulator up the flame increases, but no flame comes out of the banjo burner. I’ve googled and youtubed all to no avail. It’s a pretty simple system, something has to be blocking the Venturi, but I don’t really want to have to take by brand new burner apart. Any suggestions? Something obvious that I’m missing? My wife is not going to be happy if I have to use the kitchen stove again tomorrow…

Where are you lighting the burner at? By you saying it lights in the venturi, it sounds like you’re lighting it through the slot in the sliding air damper on the venturi. That isn’t correct. You’re supposed to light it at the orfices at the top of the burner. There’s a hole in the shield above the venturi that you can hold a lighted match to the banjo through to light the burner.

Thanks Marty. It’s 12:30 am here but I will try that in the morning. I’m sure that’s the problem. Could have sworn the instructions said to light it through the damper on the venturi. I’ll post the results but I’m sure that will solve it. Thanks for keeping my wife happy.

No problem. Hope it works, and hope you have a good brew day. :cheers:

Well, that was painfully obvious once I did it. The instructions say “light the burner through the ignition hole”, which in retrospect is pretty clear, but the only picture they have is of the venturi with the damper. Alright, I’m a dummy for not getting it, but they could be clearer on that.

Anyway, brew day is saved, I don’t have to use the kitchen stove and marital bliss is maintained.

Thanks again Marty.

know ye this - I’ve learned thru about 12+ batches now that you do have to be careful about what seems to be the regulator attachment to the propane tank. if its not seated 100% correctly you will have issues. just pay attention to this when attaching it.
mine is blazing away right now, boiling this holiday saison while it sleets outside the garage door lol.

Thanks, I will keep that in mind. The burner worked flawlessly. Mine was a high-gravity dark Belgian. No sleet though. Typical California October drought-stricken 80 degree weather.

I just tried lighting my burner for the first time. No leaks or anything. I have the lighter in the right spot and I get a pop and it seems to light, but I only see flame in the Venturi thru the damper. I can see fumes coming up thru the banjo burner holes, but no flame. I have no idea what I’m doing wrong.

Look at the hole in the steel shroud just above the “M” in the Edelmetall badge and just below the copper band on top of the burner (marked in red in the photo). This hole is what you light the burner through. Just turn the gas on and stick a lighted match through the hole and it should light. Or, if you don’t have a kettle on the burner, just hold a match to any of the holes in the top of the burner. Do NOT try to light it through the slots in the venturi plate.

Hello, i know this thread is old but i am having the same problem lighting my burner. I have tried lighting threw the lighting hole and the top of the burner and still get blow back towards the Venturi. I have tried adjusting both regulator valve and the needle valve and that sometime works. Not sure if it maybe the regulator hose that might need replacing. When it does light, this thing works great, but i think it shouldn’t be so hard to light. The needle valve also seems to adjust that well. Thanks. Dave

Sounds like you’re not getting propane through to the burner at high enough pressure. Could you be tripping the safety valve in your propane tank? I’ve seen this trip up lots of people. If you open the valve on the propane tank with the valve on the regulator even slightly open, the safety valve in the tank slams shut and only lets a trickle of gas through it. Close everything down, close the valve on the regulator all the way, wait a moment or two, and open the propane tank valve slowly. There shouldn’t be a click, otherwise the safety valve has shut again. Then open the valve on the regulator and try lighting your burner.

I would guess you’ve already tried this, but as I mentioned above, I’ve seen it happen many times.

Hello thank you for the suggestion. I have tried that. For some reason it just gets a flame by the hose and not on top, shouldn’t be so hard to light. Going to try a different regulator hose setup and see I that helps, want to also remove the needle valve and see how that works.

Probably worth trying a different hose and regulator assembly. If that doesn’t work, only other thing I could think of is a blockage somewhere. These things are sand cast, and it’s not out of the realm of possibility that something didn’t clean up properly when it was made. If it’s not in the hose, could be an obstruction inside the burner itself - maybe take the thing apart and use high pressure air or just wash it out as much as possible?

Back to Shopping at NorthernBrewer.com