Back to Shopping at NorthernBrewer.com

Strange issue with pin lock keg

Hi. I’m fairly new to kegging, and I have a batch of four pin lock kegs that I bought. I took all four apart and cleaned them and replaced the gaskets as I used them. I’ve now gotten to the fourth keg, and the CO2 post won’t screw back on. I’ve tried other CO2 posts with the same result. What’s strange is that the liquid post screws on just fine. I thought I would simply switch the liquid and CO2 tubes then, but I can’t do that. The liquid tube has these ‘Frankenstein’-like nodes on each side near the top, and the liquid hole into the keg has the analogous female slots. So that liquid tube will only go into that one spot. I initially thought that maybe the threads were stripped, but they aren’t. And as I said, the liquid post screws on just fine. What am I missing here? Thanks.

I’m not familiar with pin locks as mine are all ball locks but I see there has been no answer in almost a week. If there is a LHBS nearby you could try taking the keg and parts to them to try some new fittings and maybe they have seen this before. My LHBS has a great selection of keg parts and the owner is very knowledgeable about them. Some of the CO2 shops may also do soda and be helpful.

I recently obtained four small pin locks and noticed a couple had really tiny gas dip tubes that were stuck in the post. In my case it took a pair of needle nose pliers to remove the post and replace the o ring. All I can think of is try a post from a different keg, if the poppet is interfering with the threads another post will work fairly quickly. Otherwise, a trip to your local LHBS is a great idea. I have a ball lock that needed a new post my LHBS was able to get me straighted out.

-Tony

Back to Shopping at NorthernBrewer.com