Back to Shopping at NorthernBrewer.com

Valve on new bulkhead on new pot won't close

Hi all,

I am assembling all my all grain equipment.
Installed a new valve on a 10 gallon cooler, no probs, doesn’t leak.

now installing a valve on a new 10 gallon economy pot.

I have the valve/bulkhead installed, BUT I can’t shut the valve, it’s stuck…
I’ve tried loosening the top nut, that didn’t help.

thoughts?

thanks!

What kind of valve is it?

Is it one of those where you have to slide up a part before the handle rotates?

I was thinking the same thing as r@fink. Have you checked to make sure there is no lock on the valve? It would be a small metal piece located on the handle that you have to slide up in order to open or close the valve.

ok, thanks, everyone, I figured it out!

Don’t feel bad, the very same thing happened to me. First thing that happened after clean up was the removal of that little piece.

Paul

yup, and then I tried loosening that nut on top of the handle and that made it worse!
oh, well, now I know after installing 2,
now I am ready for all grain!

thanks everyone,
Melanie

I’m glad it worked out for you. Happy brewing, Melanie!

Back to Shopping at NorthernBrewer.com