Back to Shopping at NorthernBrewer.com

London Ale Yeast

Anyone experience a serious lag time with this yeast? I’m using Wyeast Liquid. It’s been over 24 hours and nothing is happening. I’ll check in tomorrow.

Did you make a starter? How old was the yeast? It can take up to 72hrs for fermentation to start. I bet you see something today though. I’ve only used that yeast 2x, but honestly don’t remember how long it took to start up. I do know both beers came out just fine.

I don’t particularly remember a longer lag time with London Ale yeast. This is why I make at least a small starter for every liquid yeast I use. I’m sure you’ll be fine though in a day.

I just used the yeast made a 2L starter pitched on Friday racked on Tuesday it was done it started fermenting in about 4 hrs.

I also made sure I held the temp at 65 deg in a tub with water and some ice packs.

Finally have a krausen today, but I definitely should have made a starter. Is it a terrible idea to pitch a second batch of the same yeast just to insure full fermentation?

I’ve used it several times and normally have strong activity within 8-10 hours.

What’s your OG and how old was the yeast pack?

OG was 1.060 and the pack was dated April of 2012…

Not surprising you had a lag, then. You want a starter for an OG that high and you definitely want to make a starter for 4 month old yeast. The calculator at Mrmalty figures you’ve lost 80-90% of your viable yeast by now.

Given those specs and since you didn’t use a starter, I’d send in reinforcements to ensure a complete, healthy fermentation.

Not surprising you had a lag, then. You want a starter for an OG that high and you definitely want to make a starter for 4 month old yeast. The calculator at Mrmalty figures you’ve lost 80-90% of your viable yeast by now.[/quote]

O_O well that sucks. Yeah, I’ll go ahead and hit up the LHBS.

yes. 30-48 hours is what I normally see. very odd and kinda makes you panic.

cheers.

Back to Shopping at NorthernBrewer.com